Multos Forums

   

hdb: unrecognised option -noclearpublic

Rank

Total Posts: 7

Joined 2013-04-17

PM

According to the SmartDeck manual the debugger should support the -noclearpublic option. However, when I add this option on the commandline I get the following error:

hdbunrecognised option -noclearpublic 

This option would be really convenient since now I’m using extra session memory in combination with a DEBUGGER define and have #ifdef’ed copy sections to save and restore values from the public memory segment.

Any ideas why I’m getting this error?

     
RankRankRank

Total Posts: 74

Joined 2012-02-21

PM

Hi Pim,

I’ve had a look at the source code for this and unfortunately the documentation is wrong: the option is only available in hsim.

It may be possible to add this to hdb too. I agree it would be useful. I’ll look into it.

Regards,
Chris.

     
Rank

Total Posts: 7

Joined 2013-04-17

PM

Hi Chris,

Thanks for the answer. This would definitely be usefull since the actual cards we use (ML3 mask) do not clear the public segment, they just overwrite incoming data. Since the session segment is to small for our applications we use the public segment to hold (non-secret) temporary values. So having this feature would be beneficial.

If you need testing for this, just let me know.

Pim

     
RankRankRank

Total Posts: 74

Joined 2012-02-21

PM

This will be included in the next release of SmartDeck but if any registered users would like a patch before then, please let me know and I’ll send you a link to download it.

Regards,
Chris.